РЕШИТЕ ПОЖАЛУЙСТА ЗАДАЧКУ ПО ИКТ В PASCAL ABC NET НА УРОВНЕ УЧЕНИКА 8 КЛАССА.
Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения до целых чисел. Необходимо определить :
1)разность максимальной и минимальной скоростей автомобилей;
2)количество автомобилей, скорость которых не превышала 30 км/ч.
Программа получает на вход число проехавших автомобилей N (1>N>30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести разность максимальной и минимальной скоростей автомобилей,затем количество автомобилей, скорость которых не превышала 30 км/ч.
ПРИМЕР РАБОТЫ ПРОГРАММЫ:
ВХОДНЫЕ ДАННЫЕ: ВЫХОДНЫЕ ДАННЫЕ
4;
74;
69;
63;
96;
ВЫХОДНЫЕ ДАННЫЕ : 0; 33;
Ответы на вопрос
Ответил ShirokovP
0
var N, a, i, max, num, min: integer;
begin
max := 0;
min := 301;
num := 0;
readln(N);
for i := 1 to N do
begin
readln(a);
if a > max then max := a;
if a < min then min := a;
if a <= 30 then num := num + 1;
end;
writeln(max - min);
writeln(num)
end.
Ответил ideagenerator22
0
переменная
Ответил Аноним
0
1. Современное решение
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger(ReadlnInteger);
Println(a.Max-a.Min,a.Where(p->p<=30).Count);
end.
2. Школьный вариант в стиле "ТурбоПаскаль 1983г."
var
n,i,a,k,max,min:integer;
begin
Readln(n);
max:=0;
min:=301;
k:=0;
for i:=1 to n do begin
Read(a);
if a>max then max:=a;
if a<min then min:=a;
if a<=30 then k:=k+1
end;
Writeln(max-min,' ',k)
end.
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadArrInteger(ReadlnInteger);
Println(a.Max-a.Min,a.Where(p->p<=30).Count);
end.
2. Школьный вариант в стиле "ТурбоПаскаль 1983г."
var
n,i,a,k,max,min:integer;
begin
Readln(n);
max:=0;
min:=301;
k:=0;
for i:=1 to n do begin
Read(a);
if a>max then max:=a;
if a<min then min:=a;
if a<=30 then k:=k+1
end;
Writeln(max-min,' ',k)
end.
Новые вопросы
Алгебра,
2 года назад
Математика,
2 года назад
Обществознание,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад