Информатика, вопрос задал Василёк777 , 9 лет назад

Решите, пожалуйста!!!
Ниже
записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а
потом 28.

var x, L, M: integer;
begin
    readln(x);

    L:=0; M:=0;

    while x > 0 do begin

         L:=L+1;

         if M < x then begin

           M:= M + (x mod 10) * 2;

         end;

         x:= x div 10;

    end;

    writeln(L); write(M);
end.

Ответ: 177
Мне надо решение.

Ответы на вопрос

Ответил m0nclous
0
Рас­смот­рим цикл, число шагов ко­то­ро­го за­ви­сит от из­ме­не­ния пе­ре­мен­ной x:
while x > 0 do
begin
...
  x:= x div 10;
end;
  Т. к. опе­ра­тор div остав­ля­ет толь­ко целую часть от де­ле­ния, то при де­ле­нии на 10 это рав­но­силь­но от­се­че­нию по­след­ней цифры. Из при­ве­ден­но­го цикла видно, что на каж­дом шаге от де­ся­тич­ной за­пи­си x от­се­ка­ет­ся по­след­няя цифра до тех пор, пока все цифры не будут от­се­че­ны, то есть x не ста­нет равно 0; по­это­му цикл вы­пол­ня­ет­ся столь­ко раз, сколь­ко цифр в де­ся­тич­ной за­пи­си вве­ден­но­го числа, при этом число L столь­ко же раз уве­ли­чи­ва­ет­ся на 1.
  Сле­до­ва­тель­но, ко­неч­ное зна­че­ние L сов­па­да­ет с чис­лом цифр в x. Для того, чтобы L стало L=3, x долж­но быть трёхзнач­ным.
 
    Те­перь рас­смот­рим опе­ра­тор из­ме­не­ния M:
 if M < x then
   begin
      M:= M + (x mod 10) * 2;
        end;
    Опе­ра­тор mod остав­ля­ет толь­ко оста­ток от де­ле­ния, при де­ле­нии на 10 это по­след­няя цифра x.
  Таким об­ра­зом М есть сумма удво­ен­ных цифр числа x, ко­то­рые при­ни­ма­ют чётные зна­че­ния от 0 до 18.
   

  Для по­лу­че­ния наи­мень­ше­го x по­ло­жим первую цифру x(1) = 1, она не даст вклад на тре­тьем шаге цикла, по­то­му что не будет вы­пол­нять­ся усло­вие M < x, а для того, чтобы сумма удво­ен­ных цифр была равна 28, вто­рая и треть­ся цифры долж­ны быть боль­ше нуля. Сде­ла­ем цифру x(3) мак­си­маль­но во­мож­ной, чтобы умень­шить вто­рую цифру и до­стичь ми­ни­му­ма:

x(3) = 9, тогда 9 * 2 = 18, а x(2) = (28 - 18) / 2 = 5, но тогда не вы­пол­ня­ет­ся усло­вие M < x (18 > 15) и зна­че­ние 28 не до­стиг­нет­ся.
 

x(3) = 8, тогда 8 * 2 = 16, а x(2) = (28 - 16) / 2 = 6, усло­вие M < x не вы­пол­ня­ет­ся (16 = 16) и зна­че­ние 28 не до­стиг­нет­ся.

 x(3) = 7, тогда 7 * 2 = 14, а x(2) = (28 - 14) / 2 = 7, M < x (14 < 17) и зна­че­ние 28 до­стигaется. 
Окон­ча­тель­но на­хо­дим наи­мень­шее число x: 177.
Новые вопросы