Информатика, вопрос задал kira10111990 , 6 лет назад

Решите пожалуйста!!!!!!!!!!!!!!!
Напишите программу на языке Паскаль для решения задачи:
Дан целочисленный одномерный массив, состоящий из n элементов. Найти количество элементов, которые кратны 4.

Ответы на вопрос

Ответил valgrisa
2

Ответ:

program z;

var n,i,k:integer;

m:array[1..32767] of integer;

begin

read(n);

k:=0;

for i:=1 to n do

begin

read(m[i]);

if m[i] mod 4 = 0 then k:=k + 1

end;

write(k)

end.

Объяснение:

вводим количество (1 <= n <= 32767) элементов массива (read(n);)

используя цикл со счётчиком (for i:=1 to n do):

вводим элементы массива с клавиатуры (read(m[i]);)

используя неполный условный оператор (if m[i] mod 4 = 0 then k:=k + 1) проверяем эти элементы на кратность 4

(если условие (m[i] mod 4 = 0) истинно, то увеличиваем (k:=k + 1) переменную k на 1)

выводим результат (write(k))

mod - остаток от целочисленного деления (если результат mod равен 0, то число делится без остатка, т.е. является кратным)

Приложения:

kira10111990: привет можешь написать что выходит в окне вывода
valgrisa: Добрый день! Вывод данной программы зависит от того сколько элементов массива будет введено и сколько из них будут кратны 4
valgrisa: Например, вы вводите в переменную n число 3, затем числа 4 8 12 и программа выводит 3, т.к. все эти числа кратны 4
valgrisa: Другой пример, вы вводите в переменную n число 5, затем числа 1 2 3 4 5 и программа выводит 1, т.к. только 1 число кратно 4
kira10111990: Можете пожалуйста написать полностью с цифрами я не понимаю либо я не туда вставляю данные либо это с программой проблемы
valgrisa: Добавила скрины с примерами
valgrisa: Можете написать подробнее какие данные и куда вы вставляете?
Новые вопросы