Информатика, вопрос задал Kattriine , 10 лет назад

решите плиз: составить программу которая сортирует список из N фамилий по алфавиту. решаем в паскале пожалуйста

Ответы на вопрос

Ответил AUDIOSURF
0

вот тебе от меня мой личный код pascal у меня было это задание и аж 2 петёрки поставили а вот и код:

Код Pascal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27   type mass=array[1..50] of string;   var a:mass;     i,j,n:integer; begin write('Введите кол-во фамилий: '); readln(n); for i:=1 to n do begin  write('Введите',i,'-ую фамилию: ');readln(a[i]); end;   writeln('Несортированный список:');writeln;   for i:=1 to n do writeln(a[i]);   for j:=1 to n do for i:=1 to n do if ord(a[j][1])<ord(a[i][1]) then swap(a[i],a[j]);   writeln;   for i:=1 to n do writeln(a[i]); end.  
Новые вопросы