Информатика, вопрос задал mxdxze , 1 год назад

Решите на Python.
Задача A. Родительское собрание
Формат входных данных
В первой строке записаны три натуральных числа N, M и S (N — количество родителей,
M ⩾ 2 — количество идей, S — номер идеи, предложенной классным руководителем). Идеи
пронумерованы последовательными натуральными числами, начиная с единицы.
В каждой из следующих N строк записана пара различных чисел bi
, wi
, разделённых пробелом — номер самой интересной и номер самой неинтересной идеи по мнению i-го родителя.
Информация о родителях дана в порядке строгого убывания их голосистости.
Формат выходных данных
Выведите одно число — номер идеи, выбранной родителями. Если родители не смогут
прийти к общему мнению и классному руководителю придётся вмешаться, выведите 0.

Приложения:

Ответы на вопрос

Ответил paitanbimbim
0

def parent_meeting(N, M, idea_num):

   idea_votes = [0] * (M + 1)  # массив для хранения голосов за каждую идею

   for i in range(N):

       parent_votes = list(map(int, input().split()))

       favorite_idea, disliked_idea = parent_votes

       if idea_votes[disliked_idea] == 0:

           idea_votes[favorite_idea] += 1

   

   max_votes_idea = idea_votes.index(max(idea_votes[1:]))

   

   if idea_votes[max_votes_idea] == N:

       return max_votes_idea

   else:

       return 0

# Считываем входные данные

N, M, idea_num = map(int, input().split())

# Вызываем функцию и выводим результат

result = parent_meeting(N, M, idea_num)

print(result)

Новые вопросы