Информатика, вопрос задал korzovaleksandr7758 , 6 лет назад

Решите на паскале уже пытался не понял

Приложения:

valgrisa: решить это написать программу с выводом значения a?
korzovaleksandr7758: да

Ответы на вопрос

Ответил valgrisa
2

Ответ:

program z;

var a:integer;

begin

a:=20;

while a>15 do a:=a-3;

a:=a+6;

write(a)

end.

программа выведет на экран: 20

Объяснение:

элементы блок-схемы:

1) прямоугольник - выполнение действия

2) если стрелочки в блок схеме закольцованы, то это цикл

здесь цикл с предусловием (условие указывается в ромбе)

выполняется действие a:=20 (присваивание значения переменной a)

цикл с предусловием выполняется пока условие (a > 15) истинно

тело цикла содержит действие a:=a-3 (уменьшение переменной a на 3)

по окончании цикла выполняется действие a:=a+6 (увеличение переменной a на 6)

добавлен вывод получившегося значения переменной a

цикл выполнится 2 раза:

1 раз при a = 20

2 раз при a = 17 (a = 20 - 3 = 17)

по окончании цикла а = 14 (a = 17 - 3 = 14)

по окончании программы a = 20 (a = 14 + 6 = 20)


korzovaleksandr7758: спасибо, а то я писал else then вылезала ошибка, спасибо ещё раз)
valgrisa: не за что )
Новые вопросы