Информатика, вопрос задал aliskeys , 10 лет назад

Решите 2 программы.

1) Найдите количество двухзначных чисел, которые делятся на сумму своих цифр.

2) Составьте программу вычисления количества трехзначных чисел, у которых сумма цифр является чётным числом.

ОЧЕНЬ СРОЧНО!!!

Ответы на вопрос

Ответил yasadc
0
1)uses crt;
var i,k:integer;
begin
for i:=10 to 99 do
if i mod ((i mod 10)+(i div 10))=0 then inc(k);
writeln(k);
end.
2)uses crt;
var i,k:integer;
begin
for i:=100 to 999 do
if ((i mod 10)+(i div 100)+ ((i div 10)mod 10)) mod 2=0 then inc(k);
writeln(k);
end.


Ответил Аноним
0
это же задачи на массив -_-
Ответил Аноним
0
Несогласен
Новые вопросы