Информатика, вопрос задал KroshkaXleba , 8 лет назад

РЕШИТЬ ЗАДАНИЕ НА PYTHON ПРОШУ ТЕХ КТО В НЁМ ХОРОШО РАЗБИРАЕТСЯ
Назовем число палиндромом, если оно не меняется при перестановке его цифр в обратном порядке. Напишите программу, которая по заданному числу K выводит количество натуральных палиндромов, не превосходящих K.

Входные данные
Задано единственное число K (1K100000).

Выходные данные
Необходимо вывести количество натуральных палиндромов, не превосходящих K.
Примеры
входные данный
1
выходные данные
1
входные данные
100
выходные данные
18

Ответы на вопрос

Ответил karasikov
0
def isPalindrome(num):
    if str(num) == str(num)[::-1]:
            return True
    return False

k = int(input())
ans = 0
for i in range(1, k + 1):
    if isPalindrome(i):
        ans +=1
print(ans)
Новые вопросы