Решить задачу в Паскале.
С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на экран привествие согласно введенному времени.
Ввод:
1
Вывод:
Доброй ночи
Ответы на вопрос
Ответил DejavuP
0
program myp;
var a:integer;
begin
readln(a);
if a = 1 then writeln('Доброй ночи');
end.
var a:integer;
begin
readln(a);
if a = 1 then writeln('Доброй ночи');
end.
Ответил rusnura
0
var
time : Integer; begin
writeln('Введите, который час: ');
readln(time);
if (time > 23) or (time < 0) then
writeln('Так не бывает!') else
begin
if ( time >= 0 ) and ( time < 6 ) then writeln('Доброй ночи!');
if ( time >= 6 ) and ( time < 12 ) then writeln('Доброе утро!');
if ( time >= 12 ) and ( time < 18 ) then writeln('Добрый день!');
if ( time >= 18 ) and ( time < 24 ) then writeln('Добрый вечер!');
end;
end.
time : Integer; begin
writeln('Введите, который час: ');
readln(time);
if (time > 23) or (time < 0) then
writeln('Так не бывает!') else
begin
if ( time >= 0 ) and ( time < 6 ) then writeln('Доброй ночи!');
if ( time >= 6 ) and ( time < 12 ) then writeln('Доброе утро!');
if ( time >= 12 ) and ( time < 18 ) then writeln('Добрый день!');
if ( time >= 18 ) and ( time < 24 ) then writeln('Добрый вечер!');
end;
end.
Ответил rusnura
0
Проверить код можно тут: http://195.208.237.170/WDE/
Новые вопросы