Информатика, вопрос задал AskerShavaev , 7 лет назад

решить задачу с помощью PASCAL ABC. NET. :по данному числу N распечатайте все целые степени двойки не превосходящие N в порядке возрастанию. Примечание :Операцией возведения в степень пользоваться нельзя!
Входные данные: 50
Выходные:1 2 4 8 16 32

Ответы на вопрос

Ответил vanyasokolov873
0

var n,m:integer;

begin

write('n=');

readln(n);

m:=1;

while m<n do

begin

 write(m,' ');

 m:=m*2;

end;

end.

Ответил AskerShavaev
0
спасибо
Новые вопросы