Информатика, вопрос задал Romanprokhov , 7 лет назад

Решить в Python срочно Напишите программу, которая вводит натуральное число N и выводит на экран все нату-ральные числа, не превосходящие N и делящиеся на каждую из своих цифр

Ответы на вопрос

Ответил лекция
2

n = int(input())

for i in range(1, n):

   flag = True

   for k in str(i):

       try:

           if i % int(k) != 0:

               flag = False

       except:

           flag = False

   if flag == True:

       print(i)

возможно можно проще))

Новые вопросы