Информатика, вопрос задал zamur650 , 6 лет назад

РЕШИТЬ В ПИТОНЕ!!!


Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.


Входные данные

Входная строка содержит неотрицательное число N .


Выходные данные

Программа должна вывести в столбик все цифры введённого числа, начиная с первой.


Примеры:


Входные данные Выходные данные

1234: 1 2 3 4
0: 0


Использовать функции (def)

Ответы на вопрос

Ответил valgrisa
1

Ответ:

def CvS(a):

   a = str(a)

   for i in range (len(a)):

       print (a[i])

N = int(input())

CvS(N)

Объяснение:

создадим функцию CvS, которая превращает переданное ей неотрицательное число N в строку и используя цикл с параметром выводит символы строки начиная с 0 (цифры числа) в столбик

Новые вопросы