Решить в паскале :
Написать программу решения квадратного уравнения
Ответы на вопрос
Ответил NoBrains
0
Program QuadraticEquation;
Var a, b, c, d, x1, x2:real;
Begin
Writeln('vvedite a, b, c');
Readln(a,b,c);
If A=0 then
Writeln('algoritm ne primenim');
D:=b*b-4*a*c;
If D<0 then
Writeln('deystvit resheniy net');
If D=0 then
Begin
x1:=-b/(2*a);
Writeln('x1=',x1);
End
Else
Begin
x1:=(-b+sqrt(D))/(2*a);
x2:=(-b-sqrt(D))/(2*a);
Writeln('x1=',x1, 'x2=', x2);
End;
end.
Держи!)
Var a, b, c, d, x1, x2:real;
Begin
Writeln('vvedite a, b, c');
Readln(a,b,c);
If A=0 then
Writeln('algoritm ne primenim');
D:=b*b-4*a*c;
If D<0 then
Writeln('deystvit resheniy net');
If D=0 then
Begin
x1:=-b/(2*a);
Writeln('x1=',x1);
End
Else
Begin
x1:=(-b+sqrt(D))/(2*a);
x2:=(-b-sqrt(D))/(2*a);
Writeln('x1=',x1, 'x2=', x2);
End;
end.
Держи!)
Новые вопросы
Английский язык,
2 года назад
Обществознание,
8 лет назад
Обществознание,
8 лет назад
История,
9 лет назад