Информатика, вопрос задал Аноним , 9 лет назад

Решить в Pascal АBC!!!
В некоторой школе решили набрать три новых математических класса и оборудовать кабинеты для них новыми партами. За каждой партой может сидеть два учащихся. Известно количество учащихся в каждом из трех классов. Выведите наименьшее число парт, которое нужно приобрести для них.

Входные данные
Программа получает на вход три натуральных числа: количество учащихся в каждом из трех классов (числа не превышают 1000).

Выходные данные
Выведите ответ на задачу. (Примеры : входные - 20,21,22. выходные - 32)

Ответы на вопрос

Ответил Аноним
0
// PascalABC.Net 3.0, сборка 1052
var
  a,b,c,n:integer;
begin
  Read(a,b,c);
  Writeln(((a+1) div 2)+((b+1) div 2)+((c+1) div 2))
end.

Тестовое решение:
20 21 22
32
Новые вопросы
Математика, 2 года назад