Информатика, вопрос задал NONAMEnonamezn , 2 года назад

Решить в dev c++ и желательно блок-схему
Дан массив размера N. Вывести массив на экран в строчку. Найти номер его первого локального максимума.
Локальный максимум – это элемент, который больше любого из своих соседей.
Входные данные
размерность массива: 5 0 5 89 10 100
Выходные данные 0 5 89 10 100
Номер элемента массива, первого локального минимума - 3

Ответы на вопрос

Ответил pz4t9v0d4tly
1

#include <iostream>

#include <ctime>

using namespace std;

int main() {

srand(time(0));

int N;

setlocale (LC_ALL, "Russian");

cout << "Размер массива: ";

cin >> N;

int a[N];

for(int i = 0; i<N; ++i) {

 cin >> a[i];

 cout << " ";

}

for(int i = 0; i<N; ++i) {

 cout << a[i];

 cout << " ";

}

for(int i = 0; i<N; ++i) {

 if(i==0) {

  if(a[0]>a[1]) {

   cout << endl << "Первый локальный максимум: " << a[i] << " под индексом " << i;

   break;

  }

 }

 if(i==N) {

  if(a[N]>a[N-1]) {

   cout << endl << "Первый локальный максимум: " << a[i] << " под индексом " << i;

   break;

  }

 }

 if(i!=0&&i!=N) {

  if(a[i]>a[i-1]&&a[i]>a[i+1]) {

   cout << endl << "Первый локальный максимум: " << a[i] << " под индексом " << i;

   break;

  }

 }

}

}

Новые вопросы