Решить с помощью Паскаля две задачи:
1. Составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом.
2. Составить программу, которая определяет,верно ли, что в заданном числе все цифры стоят по возрастанию.
Ответы на вопрос
Ответил kage1998
0
program gt;
var n:integer;
function chik(n:integer):integer;
var s,q:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
chik:=s;
end;
begin
read(n);
if(chik(n) mod 2=0)then writeln('yes')else writeln('no');
end.
2)
program gt;
var n,q,k,r:integer;
begin
read(n);
k:=0;r:=-1;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
if(q>=r)and(r<>-1)then k:=1;
r:=q;
end;
if(k=0)then writeln('yes')else writeln('no');
end.
var n:integer;
function chik(n:integer):integer;
var s,q:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
chik:=s;
end;
begin
read(n);
if(chik(n) mod 2=0)then writeln('yes')else writeln('no');
end.
2)
program gt;
var n,q,k,r:integer;
begin
read(n);
k:=0;r:=-1;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
if(q>=r)and(r<>-1)then k:=1;
r:=q;
end;
if(k=0)then writeln('yes')else writeln('no');
end.
Новые вопросы