Информатика, вопрос задал AadenU , 2 года назад

Решить по ПИТОНУ две задачи

3. Вам дана строка «Благотворительность». Составьте программу, которая из данной строки составит новую строку «отвратительно».

4. Написать программу, которая находит произведение первых А натуральных чисел. Число А вводится с клавиатуры.​

Ответы на вопрос

Ответил Misha1tigr
2

Ответ:

1.    

s="Благотворительность"

n=s[4]+s[5]+s[6]+s[8]+s[2]+s[10]+s[9]+s[17]+s[11]+s[12]+s[13]+s[14]+s[15]

print(n)

2.

s=int(input())

n=1

for i in range(1,s+1):

   n=n*i

print(n)


AadenU: ты уверен насчёт второго
AadenU: я пробовал через свою прогу
AadenU: но там каждый раз умножается на ноль и поэтому произведение равно нулю (((
AadenU: а ты можешь пж решить через while второе
Новые вопросы