Информатика, вопрос задал HoveringAsh , 7 лет назад

Решить на Питоне
n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Входные данные Программа получает на вход числа n и k. Выходные данные Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Примечание: При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.

Примеры:

входные данные: 7, 30
выходные данные: 5

входные данные: 7, 28
выходные данные: 0

Ответы на вопрос

Ответил georgkurmanov
0

Ответ:

Объяснение:

Решить на питоне не могу, но могу дать тебе кусок кода и объяснить его.

int n,k,a;   //объявляешь переменные n,k,a

cin>>n>>k;  //считываешь с клавы

a = (n-k%n)%n;  //находишь a, где % это остаток от деления

cout<<a; //выводишь a

Ответил bronxitfm
0
Georgkurmanov , помогите прошу у меня задача в профиле
Ответил bronxitfm
0
никто не рашет
Новые вопросы