Информатика, вопрос задал sashaegorov200396 , 7 лет назад

Решить на C++
Вид треугольника
Напишите программу, которая принимает три положительных числа и определяет вид треугольника, длины сторон которого равны введенным числам.

Формат входных данных
На вход программе подаются три числа – длины сторон существующего треугольника.

Формат выходных данных
Программа должна вывести на экран текст – вид треугольника («Равносторонний», «Равнобедренный» или «Разносторонний»).

Ответы на вопрос

Ответил NqVixer
0

#include <iostream>

using namespace std;

int main()

{

setlocale(0, "");

int a{}, b{}, c{};

cin >> a >> b >> c;

if (a == b && a == c)

cout << "Равносторонний";

else if (a == b || a == c || b == c)

cout << "Равнобедренный";

else

cout << "Разносторонний";

return 0;

}

Новые вопросы