Информатика, вопрос задал phogefe2 , 7 лет назад

( Решить и Написать на паскале) Напишите программу, которая будет выводить на экран элементы последовательности трибоначчи- первые элементы последовательности: 0,0,1,1,2,4,7,13,24,44 81,149.. . Каждый элемент, начиная с четвертого, равен сумме трех предыдущих: an= an-1 + an-2 + an-3

Ответы на вопрос

Ответил pusaxe
0

//PacalABC.NET 3.4.2

//Используется формула аналогичная формуле Бине для чисел

//Фибоначчи

const

 index = power(33, 0.5);

 a1 = power((19 + 3 * index), 1 / 3);

 a2 = power((19 - 3 * index), 1 / 3);

 b = power((586 + 102 * index), 1 / 3);

var

 n: smallint;

function tribonacthi(n: smallint): biginteger;

begin

 if (n = 1) or (n = 2) then result := 0

 else

   result := RoundBigInteger(3 * b * ((power((1 / 3 * (a1 + a2 + 1)), n - 1)) / (power(b, 2) - 2 * b + 4)));

end;

begin

 try

   n := readinteger('Введите количество элементов для вывода:');

 except

   on system.formatexception do

     writeln('Неверный формат ввода');

 end;

 for var i := 1 to n do write(tribonacthi(i), ' ');

end.

Новые вопросы