Решить двумя способами.Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. Пример: Введите число? 311 Единиц: 2
Ответы на вопрос
Ответил Студэнt
0
//PascalABC.Net 3.2
begin
var n:=readinteger('Введите число: ');
var count:=0;
repeat
if abs(n mod 10)=1 then count+=1;
n:=n div 10;
until n=0;
write ('Единиц: ', count);
end.
begin
var n:=readinteger('Введите число: ');
var count:=0;
repeat
if abs(n mod 10)=1 then count+=1;
n:=n div 10;
until n=0;
write ('Единиц: ', count);
end.
Ответил AnonimusPro
0
Program n1;
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num<>0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num<>0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
Новые вопросы