Информатика, вопрос задал arahsio789 , 6 лет назад

решение нужно в ПИТОНЕ
15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся
на 3. Программа получает на вход количество чисел в последовательности, а затем сани числа. В последовательности всегда
имеется число, оканчивающееся на 3. Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно число — количество чисел, оканчивающихся на 3.
Пример работы программы:
Входные данные выходные данные
3
13
23
2
24
Источник: ГИА

Ответы на вопрос

Ответил anonymous2010
0

Ответ:

def convertToInt(str: str) -> int:

   try:

       return int(str)

   except Exception:

       exit()

def main() -> None:

   lenNumberArray = convertToInt (

       input(

           "количество чисел: "

       )

   )

   #условия  Количество чисел не превышает 1000

   if not(0 < lenNumberArray < 1000):

       exit()

   numbers = [

       input(

           f"число {i+1}: "

       ) for i in range(lenNumberArray)

   ]

   howNumberEnd3 = 0

   for i in numbers:

       #условие Введенные числа не превышают 30 000.

       if convertToInt(i) > 30000:

           exit()

       

       if i.replace(" ", "")[-1] == "3":

           howNumberEnd3 += 1

   #Программа должна вывести одно число — количество чисел, оканчивающихся на 3.

   print(f"чисел которие заканчиваются на 3: {howNumberEnd3}")

if __name__ == "__main__":

   main()

Объяснение:

примерчик

>>> python main.py

количество чисел: 5

число 1: 3

число 2: 13

число 3: 23

число 4: 2

число 5: 24

чисел которие заканчиваются на 3: 3

Новые вопросы