Решать на Pascal ABC.net версия 3.2 сборка 1417. Написать программу, которая выполняет сравнение многоразрядных десятичных ЦЕЛЫХ чисел. То-есть вывести > если первое число больше второго; вывести < если второе число больше первого; вывести = если числа равны.
Ответы на вопрос
Ответил Аноним
0
Var a,b:uint64;
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
else Write(a,' = ',b)
End.
Begin
Write('Введите два целых числа: ');ReadLn(a,b);
if a > b then Write(a,' > ',b)
else if a < b then Write(a,' < ',b)
else Write(a,' = ',b)
End.
Ответил Аноним
0
А если Вам нужно сравнивать числа конкретного типа - например, BigInteger - это надо в условии уточнять.
Ответил Аноним
0
Ну, лично я этот термин три раза встречал, и мне никто толком не объяснял, что это именно произвольная разрядность. Кстати, в Вашей программе можно и без преобразования в BigInteger))
Ответил Аноним
0
Но если проверка не нужна - да можно .BigInteger убрать
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
begin
var a:=ReadlnString('1-е число:').ToBigInteger;
var b:=ReadlnString('2-е число:').ToBigInteger;
if a>b then Writeln('>')
else
if a=b then Writeln('=')
else Writeln('<')
end.
Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>
Замечание: разрядность чисел - произвольная.
begin
var a:=ReadlnString('1-е число:').ToBigInteger;
var b:=ReadlnString('2-е число:').ToBigInteger;
if a>b then Writeln('>')
else
if a=b then Writeln('=')
else Writeln('<')
end.
Пример
1-е число: 45685695606778795409839437392759354
2-е число: 8643603434233452532223423423525
>
Замечание: разрядность чисел - произвольная.
Новые вопросы
Алгебра,
2 года назад
Математика,
2 года назад
Алгебра,
8 лет назад
Математика,
9 лет назад
Литература,
9 лет назад