Информатика, вопрос задал КотЭюшка , 9 лет назад

Рекурсия. ПаскальABC. Составить программу для определения значения функции, заданной указанным соотношением.

Приложения:

Ответы на вопрос

Ответил Аноним
0
function f(x:integer):integer;
begin
  if abs(x+1)<=1 then f:=4
  else f:=-2*sqr(x)+sqr(f(x-1))
end;

Ответил КотЭюшка
0
спасибо большое, у вас там ошибочка, нужно не умножить, а прибавить, но это опечатка)
Ответил Аноним
0
Спасибо, я уже сам заметил и попрвил
Ответил APALoff
0
Function F(x : Real) : Real;
Begin
If abs(x+1)>1 then F:=-2*sqr(x)+sqr(f(x-1))
else F:=4;
end;
Var a : Real;
Begin
Readln(a);
Writeln(F(a));
end.

Новые вопросы