Информатика, вопрос задал yulechka076 , 7 лет назад

Ребята пожалуйста помогите написать программу на языке с++
С циклом do while
Вычислить сумму членов ряда с точностью Е=10^-2 при заданном х=0.75.
S=7.5-lnx^3/2!+lnx^5/4!
Я нашла для этого примера общий вид (прикреплю в фото) ❗❗❗❗❗
Мне нужно расписать именно этот общий вид на языке с++
Помогите пожалуйста

Приложения:

Ответы на вопрос

Ответил moboqe
0

Объяснение:

Похоже, что ряд, который показан на первом фото, не сходится.

Я написал код для ряда на втором фото

#include <stdio.h>

#include <iostream>

#include <cmath>

using namespace std;

const double EPS = 1e-2; // epsilon - точность вычисления суммы

const double X = 0.75; // x - аргумент, значение функции которого надо вычислить

double MySum(double X, double EPS)

{

double s = 0;// Тут копим сумму

double an; // Тут храним N-ый член ряда

int n; // счётчик

n = 1; // начальное значение n

an = 0; // начальное значение an

do {

 an = pow(-1, n + 2) * 2 / ((2 * n + 1)*log(X));

 s += an; // суммируем очередной член ряда

 n++; // переходим к следующему члену

} while (fabs(an) > EPS); // Суммировать будем пока член ряда an не станет достаточно маленьким по модулю

return s; // получившаяся сумма

}

int main()

{

setlocale(LC_ALL, "RUS");

cout <<"Сумма ряда с точностью до " << EPS << "= " << MySum(X, EPS) << endl;

system("pause");

return 0;

}

Если появятся вопросы смело обращайтесь

Приложения:
Новые вопросы