Информатика, вопрос задал kristina2005841 , 2 года назад

РЕБЯТА ПОМОГИТЕ!!!! В ПИТОНЕ НАДО СДЕЛАТЬ!!!!! ПОМОГИТЕ ПОЖАЛУЙСТА!!!!

В первой строке вводится число N (1<=N<=20) - количество элементов одномерного массива

Во второй строке вводится N целых чисел (ввод чисел происходит с клавиатуры)

В третьей строке вводятся целые числа a и b.


Найти сумму элементов массива, кратных a или b.


Пример входных и выходных данных

№ теста Входные данные Выходные данные

1 5

1 2 3 4 5

2 3 9

2 3

1 2 3

1 2 6


Запрещенные операторы: reverse;min;max;sum

Ответы на вопрос

Ответил restIess
3

s = 0

N = int(input())

X = [int(_) for _ in input().split()]

a, b = map(int, input().split())

for i in range(len(X)):

   if X[i] % a == 0 or X[i] % b == 0:

       s += X[i]

print(s)


kristina2005841: СПАСИБО!!!!
Новые вопросы