Ребят, жду помощи
Нужно написать программу на паскале
1) Вводи 2 слова
2)Программа пишет что 1 слово - n символов, 2 слово - n символов, а пробел символ номер N
3)Программа пишет 1 слово, а за ним первый символ 2 слова.
На этом все
mnv1962:
паскаль какой?
Ответы на вопрос
Ответил mnv1962
1
Uses crt;
var
a:string;
i,n:integer;
begin
clrscr;
writeln('Введи 2 слова через пробел');
readln(a);
n:=pos(' ',a);
writeln('1 слово ',n-1,' символов');
writeln('2 слово ',length(a)-n,' пробел - символ № ',n );
for i:=1 to n-1 do
write(a[i]);
write(a[n+1]);
readkey;
end.
var
a:string;
i,n:integer;
begin
clrscr;
writeln('Введи 2 слова через пробел');
readln(a);
n:=pos(' ',a);
writeln('1 слово ',n-1,' символов');
writeln('2 слово ',length(a)-n,' пробел - символ № ',n );
for i:=1 to n-1 do
write(a[i]);
write(a[n+1]);
readkey;
end.
Новые вопросы
Математика,
2 года назад
Другие предметы,
2 года назад
Литература,
2 года назад
Алгебра,
7 лет назад
Математика,
7 лет назад