Информатика, вопрос задал Din2stvola , 9 лет назад

Ребят решите задачи
1) Дан текст .Написать программу вставляющию после каждой запятой по одному пробелу.
2)Дан текст ,слова в тексте разделены одним и несколькими пробелами.Написатт программу выводящию все слова в алфавитном порядке.

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Pascal ABC.NET v3.1 сборка 1172

//1

Var
 s:string;
 i:integer;
begin
 readln(s);
 while i<length(s) do
 begin
 inc(i);
 if s[i]=',' then insert(' ',s,i+1);
 end;
 writeln(s);
end.

Пример ввода:
Some,awesome,test,text,
Пример вывода:
Some, awesome, test, text, 

//2

Var
 s:string;
 i,k,j:integer;
 ars:array of string;
begin
 readln(s);
 setlength(ars,length(s));
 k:=0;
 for i:=1 to length(s) do
 begin
  if (s[i]=' ') and (s[i+1]<>' ') and (i<>length(s)) then inc(k) else  ars[k]:=ars[k]+s[i];
 end;
 for i:=0 to k-1 do
  for j:=i+1 to k do
   if LowerCase(ars[i])>LowerCase(ars[j]) then
   begin
    s:=ars[i];
    ars[i]:=ars[j];
    ars[j]:=s;
   end;
 for i:=0 to k do
 writeln(ars[i]);
 end.

Пример ввода:
Очень              много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков
Новые вопросы