Ребят пожалуйста помогите написать программу для подсчета числа различных разделителей в строке. Программу на С
Приложения:

Ответы на вопрос
Ответил HRAshton
0
//Вот на Pascal, если поможет (да и раз уж можно (комменты:) )), я пытался написать на С, но есть неразрешимая для меня проблема, я ж его не изучал) Ну, в общем, попробуйте переписать на С)
var
s, k: string;
begin
readln(s);
foreach c: char in s do
if not (Char.isDigit(c) or Char.IsLetter(c)) then
if (pos(c, k) = 0) then
k := k + c;
writeln(length(k));
end.
=====================
var
s, k: string;
begin
readln(s);
foreach c: char in s do
if not (Char.isDigit(c) or Char.IsLetter(c)) then
if (pos(c, k) = 0) then
k := k + c;
writeln(length(k));
end.
=====================
Новые вопросы