Ребят,помогите составить программу в Паскале,пожалуйста!!!
Составить программу вычисления максимального значения функции y=x^2-3x+lnx при изменении аргумента x в интервале 1<=x<=5 с шагом 0.5
Ответы на вопрос
Ответил Аноним
0
1. Современный вариант
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.
Ответил NastasyaSin
0
Спасибо огромное,ты просто Бог.Такой ещё вопрос,при каком условии программа перестанет выполнять цикл??
Ответил Аноним
0
Так написано же: while x<=5 ... Как только это условие перестанет выполняться, т.е. при x>5, завершится и цикл.
Новые вопросы