РЕБЯТ, ПОМОГИТЕ ПОЖАЛУЙСТА!!!
Напишите программу заполнения массива из 20 элементов случайными числами в диапозоне от -150 до 1000. Найдите количество элементов, которые имеют нечетное значение и делятся на пять.
Ответы на вопрос
Ответил 65536
0
var a:array[1..20] of integer;
n,i:integer;
begin
for i:=1 to 20 do begin
a[i]:=random(-150,1000);
if (a[i] mod 5=0) and (a[i] mod 2<>0) then n+=1;
write(a[i],' ');
end;
writeln();
writeln('Искомых элементов: ',n);
end.
n,i:integer;
begin
for i:=1 to 20 do begin
a[i]:=random(-150,1000);
if (a[i] mod 5=0) and (a[i] mod 2<>0) then n+=1;
write(a[i],' ');
end;
writeln();
writeln('Искомых элементов: ',n);
end.
Новые вопросы
Обществознание,
2 года назад
Другие предметы,
2 года назад
Алгебра,
9 лет назад
Математика,
10 лет назад
Математика,
10 лет назад