Информатика, вопрос задал schlaff , 8 лет назад

Ребят помогите, легкая программа.Составить программу на Турбо Паскале:
Дана строка. Сформировать новую строку из 2-й, 3-й, 4-й и последней букв.

Ответы на вопрос

Ответил petyaGavrikov
0
var s1,s2:string;
begin
writeln('Введите строку:');
readln(s1);
s2:=s1[2]+s1[3]+s1[4]+s1[length(s1)];
writeln(s2);
end.

Пример:
Введите строку:
программа
рога
Ответил schlaff
0
Спасибо, только мне без массива надо было
Ответил petyaGavrikov
0
s2:=COPY(s1,2,1)+COPY(s1,3,1)+COPY(s1,4,1)+COPY(s1,length(s1),1);
Ответил Аноним
0
А тут нет массива. s[i] для строки - это обращение к её i-му символу
Новые вопросы