Ребят, очень нужна помощь.
Написать программу перевода целого числа из 10с.с. В 2с.с.
(Паскаль)
Дам много баллов!
Ответы на вопрос
Ответил manarchi
0
Ответ:
program ss102;
var a,b,c,i,v:integer;
begin
readln(a);
v:=0;
b := a;
while a > 0 do begin
b = b div 10;
c = c + 1;
end;
for i:=0 to c do begin
b:=a mod 2;
a:=(a-b) div 2;
v:=v + b*exp(i*In(10));
end;
writeln(c);
end.
Ответил AnatolyKOT
0
спасибо огромное!!!!!!!
Новые вопросы