Информатика, вопрос задал wolfyz , 1 год назад

Ребят, мне нужно чтобы вы сделали программу на уровне 8 класса, И КАЖДУЮ СТРОЧКУ ОПИСАЛИ И ОБЪЯСНИЛИ! Сейчас сдаю онлайн, у вас 2.5 часа((( ПОЖАЛУЙСТА ПОМОГИТЕ!!! ДАЮ 100 БАЛОВ
Напишите программу, которая в последовательности целых чисел определяет среднее арифметическое чисел, кратных 4 и 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: среднее арифметическое чисел с точностью до одного знака после запятой, кратных 4 и 5. Если таких чисел нет, то программа должна вывести одно слово: “NO”. ВНИМАНИЕ! НАПИШИТЕ КОД ПОЛНОСТЬЮ, А ПОТОМ ОТДЕЛЬНО ОПИШИТЕ, ЧТОБЫ Я РАЗОБРАЛСЯ

Ответы на вопрос

Ответил nullptr53
0

Ответ:

program AverageMultiples;//Объявляем имя программы

var

num, sum, count: integer;//Создаем переменные(целочисленные), номер, сумма, количество

average: real;//И вещественную переменную(с запятой

begin//Начинаем программу(выполнение всех операций)

sum := 0;//Определяем переменную sum

count := 0;//Определяем переменную count

repeat//repeat и until, это тоже что и do.. while.. Операции повторяются до тех пор пока условие нарушится

readln(num);//Запрашиваем ввод, и сохраняем в переменной num

if (num = 0) then//Если введенное число 0, останавливаем операцию

break;

if ((num mod 4 = 0) and (num mod 5 = 0)) then//Похоже на % в питоне, определяем кратно ли число 4 и 5

begin//Начало

sum := sum + num;//Прибавляем к к переменной sum, введенное нами ранее число, тем самым получая сумму всех чисел

count := count + 1;#Прибавляем 1 к count, эта переменная кол-во введенных чисел

end;

until false;#Это блок кода будет выполнятся до тех пор пока значение условия не станет false(ложно)

if (count > 0) then//Если мы ввели какието числа(кол-во введенных чисел больше 0, тогда:

begin//Начало

average := sum / count;//Считаем среднее арифмитическое, разделив сумму чисел на количество чисел

writeln('Average: ', average:0:1);//Выводим результат

end//Конец

else//Иначе

writeln('NO');//Выводим NO в консоль

end.//Конец программы

Новые вопросы