Информатика, вопрос задал stalkershamansh , 8 лет назад

Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto)

Ответы на вопрос

Ответил trunka
0
var
a,b,c,x1,x2,d:real;
begin
write('Введите A='); readln(a);
write('Введите B='); readln(b);
write('Введите C='); readln(c);
D:=b*b-4*a*c;
if D<0 then begin
writeln('Нет корней');
end;
if D=0 then begin
writeln('x1=',-b/(2*a))
end;
if D>0 then begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1);
writeln('x2=',x2);
end;
end.
Ответил stalkershamansh
0
C goto
Ответил stalkershamansh
0
GOTO
Новые вопросы