Информатика, вопрос задал reiderman4 , 2 года назад

разработать алгоритм и написать программу, которая в последовательности целых чисел определяет кол во чисел, кратных 4 или 9 Программа получает на вход целые числа, ко­ли­че­ство введённых чисел не­из­вест­но, по­сле­до­ва­тель­ность чисел за­кан­чи­ва­ет­ся чис­лом 0 (0 − при­знак окон­ча­ния ввода, не вхо­дит в по­сле­до-ва­тель­ность).

Ко­ли­че­ство чисел не пре­вы­ша­ет 1000. Введённые числа по мо­ду­лю
не пре­вы­ша­ют 30 000.

Про­грам­ма долж­на вы­ве­сти одно число: ко­ли­че­ство чисел, крат­ных 4 или 9.​

Ответы на вопрос

Ответил guwanchwepayew9
1

Ответ:

//c++

#include<bits/stdc++.h>

using namespace std;

int main()

{

   int a[1000]={}, c=0, res=0;

for(int i=0; i<1000; i++)

{

    cin>>a[i];

    c++;

    if(a[i]==0)break;

}

for(int i=0; i<c; i++)

{

    if(a[i]%4==0 || a[i]%9==0)res++;

}

cout<<res<<endl;

 

   return 0;

}

Объяснение:

Новые вопросы