Информатика, вопрос задал mrfroost5 , 1 год назад

Рассмотрим линейный массив целых чисел K [1..50]. Напишите программу на языке Pascal, используя процедуру, которая отображает положительные элементы на экране.

Ответы на вопрос

Ответил BobbyFresnel
0

Ответ:

const

 k = 10;

type

 tK = array[1..k] of integer;

var

 i: byte;

 a: tK;

procedure PrintPos(a: tK);

var

 i: byte;

begin

 for i := 1 to k do

   if a[i] > 0 then write(a[i], ' ');

 writeln;

end;

begin

 for i := 1 to k do

   Read(a[i]);

 PrintPos(a);

end.

Новые вопросы