Информатика, вопрос задал ivanakin37 , 2 года назад

Пж помогите написать программу на языке паскаль

Приложения:

Ответы на вопрос

Ответил vintt
1

1) var x:integer;

begin

readln (x);

if x mod 2=0 then

writeln ('Четное')

else

writeln ('Нечетное');

end.

2) var x,y,z,mx,mn:integer;

begin

readln (x,y,z);

x:=x*x;

y:=y*y;

z:=z*z;

mx:=max(x,y,z);

mn:=min(x,y,z);

writeln (mx);

writeln (mn);

end.

3)   var x,y,z:integer;

begin

readln (x);

while x>0 do begin

z:=x mod 10;

x:=x div 10;

if z=3 then

 y:=y+1;

end;

writeln (y);

end.


ivanakin37: Спасибо огромное
vintt: Решение номера 4
4) var x,y,z:integer;
begin
readln (x);
case x of
1,3,5,7,8,10,12: Writeln ('31');
2: Writeln ('28');
4,6,9,11: Writeln ('30');
end;
end.
Новые вопросы