Информатика, вопрос задал yaiz1534 , 7 лет назад

PYTHOOOONNNNN
На вход программы получаем число X. Причём 10000<= X <=1000000

Напишите программу, которая находит сумму цифр числа на чётных местах и сумму цифр числа на нечётных местах (места нумеруем с 0 и справа на лево). Например:



987851

Сумма чётных = 17

Сумма нечётных = 21​

Ответы на вопрос

Ответил LuciFear45
0

Ответ:

x = input('X: ')

summach = 0

summanech =0

for i in range(1, len(x)+1):

   if i % 2 == 0:

       summach += int(x[i-1])

   else:

       summanech += int(x[i-1])

print('Сумма чётных = ' + str(summach))

print('Сумма нечётных = ' + str(summanech))

Чуть поменял прошлую прогу.


LuciFear45: Просто я на знания захожу изредка
LuciFear45: от скуки
yaiz1534: да
yaiz1534: дс есть
yaiz1534: за скину
LuciFear45: хочется иногда что-нибудь простое по программированию порешать, ищу такие задачи
LuciFear45: Жду
yaiz1534: Perfecto#2894
LuciFear45: Добавил
yaiz1534: принял все спс
Новые вопросы