Информатика, вопрос задал l8972102 , 1 год назад

python .Заданы данные о мощности двигателя (в лошадиных силах – л.с.) и стоимости
n=10 легковых автомобилей. Составить программу, определяющую общую стоимость
автомобилей, у которых мощность двигателя превышает 100 л.

Ответы на вопрос

Ответил leprekon882
0

powers = [80, 120, 150, 200, 90, 110, 130, 140, 160, 170]

costs = [10000, 20000, 30000, 40000, 15000, 25000, 35000, 45000, 55000, 65000]

total_cost = 0

for power, cost in zip(powers, costs):

   if power > 100:

       total_cost += cost

print(total_cost)

В результате работы этой программы на экран будет выведена общая стоимость автомобилей, у которых мощность двигателя превышает 100 л.с.

315000

Приложения:
Новые вопросы