Информатика, вопрос задал ftnwww , 1 год назад

Python язык пайтон помогите пж

Приложения:

Ответы на вопрос

Ответил Kadijo
1

Ответ:

1 Дан двумерный массив. Составьте программу, которая удаляет все числа, которые делятся на три без остатка, а на их место вставьте знак *

m = [[1, 2, 3], [4, 5, 6], [9, 2, 7]]

for i in range(len(m)):

   for j in range(len(m[i])):

       if m[i][j] % 3 == 0:

           m[i][j] = '*'

print(m)

2. Дан двумерный массив. Составьте программу, которая находит в этом массиве четные числа и добавляет в новый одномерный массив. Получившийся список четных чисел добавляется в данный двумерный массив.

m = [[1, 2, 3], [4, 5, 6], [7, 8, 6]]

even_nums = []

for row in m:

   for num in row:

       if num % 2 == 0:

           even_nums.append(num)

m.append(even_nums)

print(m)

Объяснение:

Новые вопросы