Информатика, вопрос задал sagsdvwretredgsfdv , 7 лет назад

Python. В городе были проведены N опросов. В каждом опросе участники ставили "Да" или "Нет". Для каждого опроса результат считается положительным, если в любом из них количество положительных больше числа отрицательных. Напишите программу, которая выводит результат для каждого из опросов.

Вводные данные: в первой строке пишется число N, количество опросов. Затем пишется N строк, на которых написаны числа через пробел. Числа являются 1 или 0, что означает "Да" или "Нет".

Выходные данные: для каждого из опросов на отдельной строке вывести "Positive", если количество 1 больше или равно количеству 0, и "Negative" в противном случае. Напишите данную программу используя функции.
Пример 1
Ввод:
5
1 0 0 1 1
0 1
1
0 1 0 1 0
1
Вывод:
Positive
Positive
Positive
Negative
Positive

Ответы на вопрос

Ответил lozromanik
1

Відповідь:

import math

def vivodi(n):

   l=[]

   for i in range(n):

       l.append(list(map(int,input().split())))

   for i in l:

       if sum(i)>=math.ceil(len(i)/2):

           print("Positive")

       else:

           print("Negative")

a=int(input())

vivodi(a)

можно и лучше, ток как- не знаю

Новые вопросы