Информатика, вопрос задал artempula61 , 2 года назад

PYTHON!!! Срочно пж
В этой задаче требуется проверить, есть ли в числе N две цифры 6?
Формат входных данных
Дано целое число N (0 ≤ N ≤ 100 000 000).
Формат выходных данных
Требуется вывести «YES», если в N есть две (или более) цифр 6, или «NO», если нет. Обратите внимание, что кавычки выводить не требуется.
входные данные выходные данные

646



YES

42



NO

Ответы на вопрос

Ответил merkkaa
3

while 1:

   N = int(input())

   

   if 0 <= N <= 100000000:

       break

if str(N).count("6") >= 2:

   print("YES")

else:

   print("NO")

Ответил 4688f71163
3

Ответ:

Решение на скриншоте

Объяснение:

В проверке сразу узнаем, встречается ли в введенном числе (кстати, взятом в строковом типе без преобразований -> int) цифра 6 2 или более раз.

Приложения:
Новые вопросы