Информатика, вопрос задал kuptsov2010 , 1 год назад

PYTHON!!! СРОЧНО пожалуйста!


Условие

Дана непустая последовательность целых чисел, оканчивающаяся числом 100

. Необходимо определить, есть ли в последовательности число 77

.


Формат входных данных

Вводятся до 215

целых чисел ai(−215≤ai≤215−1;ai≠100). После последнего числа из последовательности вводится число 100

.

Формат выходных данных

Выведите «YES», если число 77 присутствует в последовательности, и «NO» в противном случае.



входные данные выходные данные



13 YES
1
42
10
77
123
100


1 NO
2
1000
99
100

Ответы на вопрос

Ответил Аноним
1

Код Python:

nums = []

n = int(input())

while n != 100:

   nums.append(n)

   n = int(input())

if 77 in nums:

   print('YES')

else:

   print("NO")

Приложения:
Новые вопросы