Информатика, вопрос задал artempula61 , 2 года назад

Python!!! СРОЧНО пожалуйста
Дано целое число n. Требуется найти количество четных цифр отличных от нуля в записи этого числа.
Формат входных данных

На вход программе подается одно целое неотрицательное число n
(n≤231−1).
Формат выходных данных

Требуется вывести одно целое число — ответ на задачу.
входные данные выходные данные

13



0

42



2


ZimmerGoRuR: Могу на C++ решить, на Python лень.. А так задача изи.
artempula61: не изучаю питон
ZimmerGoRuR: Я могу расписать что как.
artempula61: давай
ZimmerGoRuR: Ладно, расписывать лень, щас на пайтоне напишу.
artempula61: окей
ZimmerGoRuR: Братан_
ZimmerGoRuR: Я посмотрел твой профиль...
ZimmerGoRuR: Ты тоже в школе программистов учишься? Я на курсе C++, я так понимаю ты на Python?

Ответы на вопрос

Ответил ZimmerGoRuR
2

Ответ:

Честно говоря Python я не очень знаю, но думаю как то так... Я еще скину C++, т.к. он мне дается намного легче чем Python.

Python:

n = int(input())

countEvenNumber = 0

while n:

   d = n % 10

   if d % 2 == 0:

       countEvenNumber = countEvenNumber + 1

   n = n / 10

print (countEvenNumber)

С++:

#include <iostream> // подключение библиотеки ввода и вывода. (В Python ее не надо подключать)

using namespace  std; // Сокращение операций ввода и вывода. (В Python ее не надо подключать)

int main ()             //Это главная функция где храниться весь код (В Python ее не надо писать)

{

   int n, countEvenNumbers = 0; // создаем переменную n где будем вводить наше число. И переменную счетчик countEvenNumbers = 0

   cin >> n;  // вводим число n

   while (n) // начинаем ход цикла

   {

       int d = n % 10; // берем последнюю часть числа n (к примеру возьмем число 48, остаток от деления берет число 8)

       if (d % 2 == 0) // проверяем число на четность

           countEvenNumbers++; // если число четное то переменную счетчик увеличиваем на 1

       n /= 10; // переворачивает число.

   }

   cout << countEvenNumbers << " "; // вывод на экран

}

P.S. На C++ все отлично работает

Новые вопросы