Информатика, вопрос задал Manyak1ove , 7 лет назад

Python !СРОЧНО!
1. Збережіть назви мов світу, які вводяться в одному рядку через пропуск, у списку. Простежте за тим, щоб елементи у списку не зберігались в алфавітному порядку. Відсортуйте список в алфавітному порядку і виведіть його елементи в рядку через пропуск.
2. Вводиться список чисел. Всі числа списку знаходяться в одному рядку. Незмінюючи його і не використовуючи додаткові списки, визначте, яке число в цьому списку зустрічається найчастіше. Якщо таких чисел декілька, виведіть будь-яке з них.
3. Напишіть програму, яка приймає послідовність чисел, розділених комами, від користувача і створює список і кортеж з цими числами.


Manyak1ove: Вводится список чисел. Все числа списке находятся в одной строке. Не меняя его и не используя дополнительные списки, определите, какое число в этом списке встречается чаще всего. Если таких чисел несколько, выведите любое из них.
Manyak1ove: Это 2
Manyak1ove: Напишите программу, которая принимает последовательность чисел, разделенных запятыми, от пользователя и создает список и кортеж с этими числами.
Manyak1ove: Это 3
tutu007: В 1 задании просто приходит строка: Русский Английский Немецкий Украинский?
tutu007: или нужно по словам определять что это за язык?
Manyak1ove: Та там кроме этого ничего не написано
Manyak1ove: Сделай как понял
tutu007: пропуск - пробел?
Manyak1ove: Да

Ответы на вопрос

Ответил tutu007
1

Ответ:

1.Задание

string=input()

string=string.split(" ")

string.sort()

print(*string)

2.Задание

massiv=[int(input()) for i in range(int(input("Введите длину списка: ")))]

max_count=0

for i in massiv:

   if massiv.count(i)>max_count:

       max_num=i

       max_count=massiv.count(i)

print("Чаще всего встречается:",max_num)

3.Задание

integers=input().split(",")

integers_list=list(map(int,integers))

integers_tuple=tuple(map(int,integers))

print(integers_list,integers_tuple)


Manyak1ove: Может с тобой как-то можно связываться? Кроме знаний
tutu007: да, в личку знаний напиши, а то тут комменты репортят
Manyak1ove: Пишет что нельзя написать
Manyak1ove: Мы отключили личные сообщения и комментарии в профилях.
Пожалуйста, используйте комментарии к вопросам и ответам для уточнений. Пожалуйста, за дополнительной информацией обратитесь к статье в Общих вопросах.
tutu007: а, ну тогда тут напиши где связаться можно с тобой
tutu007: только номер телефона лучше не оставляй, а то потом спамить будут звонками
Manyak1ove: ДС подойдёт?
Manyak1ove: Manyak#1953
tutu007: да
tutu007: отправил
Новые вопросы