Информатика, вопрос задал doppelgan , 7 лет назад

!Python с помощью цикла while!


Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5.​

Ответы на вопрос

Ответил badnsnus
3

Ответ:

n = int(input())

maxc = -100000000

while n > 0:

   a = int(input())

   if a % 5 == 0:

       maxc = max(maxc,a)

   n -= 1

print(maxc)


LuciFear45: нет, не всё
LuciFear45: А если нужное число равно -100000005?
LuciFear45: допустим оно единственное кратное пяти
LuciFear45: в условии сказано лишь то, что число не больше 30к
LuciFear45: значит оно может быть бесконечно маленьким
restIess: Последовательность натуральных чисел, откуда там -100000005?)
LuciFear45: пропустил этот момент в условии, прости.
LuciFear45: Всё правильно тогда.
restIess: Ну тут лучше взять maxc за 0, так понятнее, да и памяти меньше занимает
LuciFear45: Ага.
Ответил LuciFear45
2

Ответ:

x = int(input())

a = 0

z = 0

lel = ':)'

while a < x:

   a += 1

   f = int(input())

   if f%5:

       if lel == ':)':

           lel = f

       else:

           lel = max(lel,f)

print(lel)

Если есть вопросы, пиши

Новые вопросы