Информатика, вопрос задал nurikic , 2 года назад

PYTHON Рейтинг бакалавра заочного отделения при поступлении в магистратуру определяется средним баллом по диплому, умноженным на коэффициент стажа работы по специальности, который равен: нет стажа – 1, меньше 2 лет – 13, от 2 до 5 лет – 16. Составить программу расчета рейтинга при заданном среднем балле диплома (от 3 до 5) и вывести сообщение о приеме в магистратуру при проходном балле 45.

Ответы на вопрос

Ответил DlowPro
2

Python 3.7:

point = float(input('Введите ваш средний балл: '))

while not(3 <= point <= 5):

   point = float(input('Введите ваш средний балл: '))

work_time = float(input('Введите ваш стаж работы по специальности: '))

if work_time == 0:

   k = 1

elif work_time < 2:

   k = 13

else:

   k = 16

print('Вы приняты в магистратуру!' if k*point >= 45 else 'Вы не приняты в магистратуру.')

Новые вопросы