Информатика, вопрос задал flamasters69life , 1 год назад

PYTHON!!!!! Решите дав коментарии !!!!!!!
Задача «Максимальное число идущих подряд равных элементов»

Условие
Дана последовательность натуральных чисел, завершающаяся числом 0. Определите, какое наибольшее число подряд идущих элементов этой последовательности равны друг другу.
Входные данные
1 1
2 7
3 7
4 9
5 1
6 0


flamasters69life: при той последовательности что я дала там 2
Аноним: найти получается сколько одинаковых элементов идёт подряд?
flamasters69life: угу
Аноним: а комменты сами не напишете?)
flamasters69life: Родная, я просто хочу разобраться, мне вообще нужно из этого сделать блок-схемы)
flamasters69life: поэтому хотелось бы с комментами
Аноним: Та опять меня за дефку приняли из-за авы, аааааа :D
flamasters69life: простите :)))))
Аноним: Не, сори, мои объяснения это как руководство по сбору холодильника на китайском, чет написано и тоже ничего не ясно
flamasters69life: спасибо в любом случае

Ответы на вопрос

Ответил SmEgDm
2

firstNumber = secondNumber = 1

currentCount = maxCount = 0

while firstNumber * secondNumber != 0:

 firstNumber, secondNumber = map(int, input().split())

 if firstNumber == secondNumber:

   currentCount += 1

 else:

   maxCount = max(maxCount, currentCount)

   currentCount = 0

print(maxCount)

Новые вопросы