Информатика, вопрос задал artempula61 , 2 года назад

PYTHON!!!!! пж срочно
Дано восьмизначное число, необходимо написать в строку каждую цифру данного числа через пробел, начиная с разряда единиц.
Формат входных данных
Дано целое число N (10 000 000 ≤ N ≤ 99 999 999).
Формат выходных данных
Строка, состоящая из цифр числа N, начиная с разряда единиц. Числа записываются через пробел.
Примечания

В Питоне для печати в одну строку:
входные данные выходные данные

48823168



8 6 1 3 2 8 8 4

99856775



5 7 7 6 5 8 9 9

Ответы на вопрос

Ответил pinguinbird
5

Решение через целочисленное деление и массив:

a = []

value = int(input('Введите восьмизначное число: '))

while value > 0:

   a.append(value%10)

   value = value // 10

print(*a)

То же самое, только без массива:

value = int(input('Введите восьмизначное число: '))

while value > 0:

   print(value%10, end=' ')

   value = value // 10

Работаем с числом как со строкой:

value = input('Введите восьмизначное число: ')

for digit in value[::-1]: print(digit, end=' ')

И ещё короче:

value = input('Введите восьмизначное число: ')

print(*value[::-1])

Новые вопросы